[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

(usagi-users 00037) Re: sin6_scope_id and 2.2.x kernel



On/Dnia Sun, Nov 19, 2000 at 09:42:43AM +0900, YOSHIFUJI Hideaki / ?$B5HF#1QL@?(B wrote/napisał(a)
> > > If you introduce sin6_scope_id into linux-2.2.x,
> > > binaries on glibc-2.1 systems (including binaries
> > > build on glibc-2.1 systems) encounter many random problem.
> > IMO you are wrong here because all such binaries && linux 2.4
> > (so sin6_scope_id in kernel) are working fine without almost
> > any problems (one problem is lack of sin6_scope support in glibc,
> > so troubles with link-local addresses)
> 
> You are wrong.
> There are possibility of binary incompatibility
I don't understand in which situation binary incompatibility
will occur. 

> and security flaws.
Maybe this but not binary incompatibility (IMHO).

> (or, convince them introduce linux-2.2 hack into glibc-2.2.)
I dislike hacks. I preffer to fix broken 2.2 kernel.

> > (, or usagi linux-2.2.x).
> > when we were testing it we got problems such as invalid argument
> > in connect() even for global v6 addresses etc so it was unusable.
> 
> Why don't you report it to us?
well, I should.

> Anyway, this patch against glibc-2.2 will help you.
> (this was contributed to glibc without linux-2.2 hack.)
our glibc 2.2 has this patch applied (without linux-2.2 hack)
and we really don't want to add hacks.

 
> Hideaki YOSHIFUJI @ USAGI Project  <yoshfuji@xxxxxxxxxxxxxx>

-- 
Arkadiusz Miśkiewicz, AM2-6BONE    [ PLD GNU/Linux IPv6 ]
http://www.t17.ds.pwr.wroc.pl/~misiek/ipv6/   [ enabled ]