[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

(usagi-users 00039) router solicitation



Linux version 2.4.0-test11 (root@arm) (gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #5 śro lis 22 10:27:44 CET 2000

usagi patch: 20001113

/proc/sys/net/ipv6/conf# cat {all,default,eth0,t17}/autoconf \
			     {all,default,eth0,t17}/router_solicitations
0
0
0
0
0
0
0
0

so it shouldn't send any RS etc but it still does:
Nov 23 19:07:39 arm kernel: send_rs: send RS message
Nov 23 19:07:43 arm kernel: eth0: no IPv6 routers present

The problem is that when all my network scripts set up all devices,
addresses and routing I have:
[root@arm /root]# ip -6 r
3ffe:8010:34:19::/64 dev eth0  proto kernel  metric 256  mtu 1500
fe80::/10 dev eth0  proto kernel  metric 256  mtu 1500
fe80::/10 via :: dev t17  proto kernel  metric 256  mtu 1480
ff00::/8 dev eth0  proto kernel  metric 256  mtu 1500
ff00::/8 dev t17  proto kernel  metric 256  mtu 1480
default via fe80::9c11:d7f3 dev t17  metric 1024  mtu 1480
unreachable default dev lo  metric -1  error -101

but just moment after "kernel: eth0: no IPv6 routers present"
bogus route (default to eth0) is added by kernel:

[root@arm /root]# ip -6 r
3ffe:8010:34:19::/64 dev eth0  proto kernel  metric 256  mtu 1500
fe80::/10 dev eth0  proto kernel  metric 256  mtu 1500
fe80::/10 via :: dev t17  proto kernel  metric 256  mtu 1480
ff00::/8 dev eth0  proto kernel  metric 256  mtu 1500
ff00::/8 dev t17  proto kernel  metric 256  mtu 1480
default dev eth0  proto kernel  metric 256  mtu 1500
default via fe80::9c11:d7f3 dev t17  metric 1024  mtu 1480
unreachable default dev lo  metric -1  error -101
[root@arm /root]#

I don't know why.
Any ideas ?

(t17 is sit tunnel)

btw. I didn't check that 2.2.x fix for ,,invalid argument''
     because I still don't have 2.2 kernel (and newer will :)
     
-- 
Arkadiusz Miśkiewicz, AM2-6BONE    [ PLD GNU/Linux IPv6 ]
http://www.t17.ds.pwr.wroc.pl/~misiek/ipv6/   [ enabled ]