[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

(usagi-users 03964) Re: umip 0.4 mipv6 daemon compile problem



Hi Bence, i have sometimes the same error, just delete all the sources
of the umip daemon and try again, but do a apt-get install flex, because
i think you dont have on your system.

Regards Luis

El vie, 05-10-2007 a las 23:16 +0200, SZTANYIK Bence Tamas escribiÃ:
> Dear List,
> 
> I'm having problems compiling the umip 0.4 mipv6 daemon on Ubuntu
> GutsyGibbon with the kernel Linux 2.6.23-rc9.
> Kernel configuration and other things seem to be OK, but during running
> make, the process hangs at running ylwrap. I tried to google around, but
> had no success. I also tried to run configure with --enable-vt and
> --with-builtin-crypto.
> 
> Any ideas would be appriciated.
> 
> Thank you in advance!
> 
> Cheers,
> 	Bence
> 
> documento de texto sencillo adjunto (mip6-compile.err)
> root@ha:/usr/src/mipv6-daemon-umip-0.4# ./chkconf_kernel.sh
> 
> Checking kernel configuration...
> Using /proc/config.gz
> 
> All kernel options are as they should.
> 
> root@ha:/usr/src/mipv6-daemon-umip-0.4# CPPFLAGS='-isystem
> /usr/src/linux-2.6.22/include/' ./configure
> checking for a BSD-compatible install... /usr/bin/install -c
> checking whether build environment is sane... yes
> checking for a thread-safe mkdir -p... /bin/mkdir -p
> checking for gawk... no
> checking for mawk... mawk
> checking whether make sets $(MAKE)... yes
> checking build system type... i686-pc-linux-gnu
> checking host system type... i686-pc-linux-gnu
> checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables... 
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ISO C89... none needed
> checking for style of include used by make... GNU
> checking dependency style of gcc... gcc3
> checking for ranlib... ranlib
> checking how to run the C preprocessor... gcc -E
> checking for grep that handles long lines and -e... /bin/grep
> checking for egrep... /bin/grep -E
> checking whether gcc needs -traditional... no
> checking for egrep... (cached) /bin/grep -E
> checking for flex... no
> checking for lex... no
> checking for bison... bison -y
> checking for gawk... (cached) mawk
> checking for a BSD-compatible install... /usr/bin/install -c
> checking whether ln -s works... yes
> checking whether make sets $(MAKE)... (cached) yes
> checking for sed... sed
> checking for indent... indent
> checking for an ANSI C-conforming const... yes
> checking for inline... inline
> checking for C/C++ restrict keyword... __restrict
> checking for working volatile... yes
> checking for ANSI C header files... yes
> checking for sys/types.h... yes
> checking for sys/stat.h... yes
> checking for stdlib.h... yes
> checking for string.h... yes
> checking for memory.h... yes
> checking for strings.h... yes
> checking for inttypes.h... yes
> checking for stdint.h... yes
> checking for unistd.h... yes
> checking whether byte ordering is bigendian... no
> checking for pid_t... yes
> checking for size_t... yes
> checking whether time.h and sys/time.h may both be included... yes
> checking for stdbool.h that conforms to C99... yes
> checking for _Bool... yes
> checking for ANSI C header files... (cached) yes
> checking for sys/wait.h that is POSIX.1 compatible... yes
> checking arpa/inet.h usability... yes
> checking arpa/inet.h presence... yes
> checking for arpa/inet.h... yes
> checking fcntl.h usability... yes
> checking fcntl.h presence... yes
> checking for fcntl.h... yes
> checking sys/ioctl.h usability... yes
> checking sys/ioctl.h presence... yes
> checking for sys/ioctl.h... yes
> checking sys/param.h usability... yes
> checking sys/param.h presence... yes
> checking for sys/param.h... yes
> checking time.h usability... yes
> checking time.h presence... yes
> checking for time.h... yes
> checking syslog.h usability... yes
> checking syslog.h presence... yes
> checking for syslog.h... yes
> checking vfork.h usability... no
> checking vfork.h presence... no
> checking for vfork.h... no
> checking for fork... yes
> checking for vfork... yes
> checking for working fork... yes
> checking for working vfork... (cached) yes
> checking sys/select.h usability... yes
> checking sys/select.h presence... yes
> checking for sys/select.h... yes
> checking sys/socket.h usability... yes
> checking sys/socket.h presence... yes
> checking for sys/socket.h... yes
> checking types of arguments for select... int,fd_set *,struct timeval *
> checking return type of signal handlers... void
> checking for vprintf... yes
> checking for _doprnt... no
> checking for wait3 that fills in rusage... yes
> checking for memset... yes
> checking for select... yes
> checking for socket... yes
> checking for strdup... yes
> checking for strerror... yes
> configure: *** checking for additional external libraries
> checking for clock_gettime... no
> checking for clock_gettime in -lrt... yes
> checking for dlopen... no
> checking for dlopen in -ldl... yes
> checking for pthread_create in -lpthread... yes
> checking for rtnl_talk in -lnetlink... no
> checking for HMAC_Init in -lcrypto... yes
> configure: *** checking for optional features
> checking whether to use builtin crypto... (cached) no
> checking whether to enable debug messages... (cached) yes
> checking whether to enable debug virtual terminal... (cached) no
> configure: *** checking inet6_opt for RFC3542: Advanced IPv6 Socket API
> support
> checking for inet6_opt_find... yes
> configure: *** checking inet6_rth for RFC3542: Advanced IPv6 Socket API
> support
> configure: *** checking RH2 for RFC4584: Extension to Socket API for MIPv6
> checking whether IPV6_RTHDR_TYPE_2 is declared... no
> configure: *** checking for Mobile IPv6 support in kernel headers
> checking whether IFA_F_HOMEADDRESS is declared... yes
> configure: *** checking for Mobile IPv6 extensions in system headers
> checking netinet/in.h usability... yes
> checking netinet/in.h presence... yes
> checking for netinet/in.h... yes
> checking netinet/ip6.h usability... yes
> checking netinet/ip6.h presence... yes
> checking for netinet/ip6.h... yes
> checking netinet/icmp6.h usability... yes
> checking netinet/icmp6.h presence... yes
> checking for netinet/icmp6.h... yes
> checking netinet/ip6mh.h usability... no
> checking netinet/ip6mh.h presence... no
> checking for netinet/ip6mh.h... no
> checking for struct ip6_ext.ip6e_nxt... yes
> checking for struct ip6_opt_home_address.ip6oha_type... no
> checking for struct ip6_rthdr2.ip6r2_nxt... no
> checking for struct mip_dhaad_req.mip_dhreq_hdr... no
> checking for struct mip_dhaad_rep.mip_dhrep_hdr... no
> checking for struct mip_prefix_solicit.mip_ps_hdr... no
> checking for struct mip_prefix_advert.mip_pa_hdr... no
> checking for struct nd_opt_homeagent_info.nd_opt_hai_type... no
> configure: creating ./config.status
> config.status: creating Makefile
> config.status: creating libnetlink/Makefile
> config.status: creating libmissing/Makefile
> config.status: creating src/Makefile
> config.status: creating man/Makefile
> config.status: creating config.h
> config.status: config.h is unchanged
> config.status: executing depfiles commands
> configure: settings
> 
> MIPL Mobile IPv6 for Linux version 2.0.2-umip-0.4
> 
>   Use built-in crypto: ............ no
>   Use OpenSSL crypto library: ..... yes
>   Enable debugging mode: .......... yes
>   Enable virtual debug terminal: .. no
> 
>   Build target: i686-pc-linux-gnu
>   CPPFLAGS: -isystem /usr/src/linux-2.6.22/include/
> 
> root@ha:/usr/src/mipv6-daemon-umip-0.4# make
> make  all-recursive
> make[1]: Entering directory `/usr/src/mipv6-daemon-umip-0.4'
> Making all in libmissing
> make[2]: Entering directory `/usr/src/mipv6-daemon-umip-0.4/libmissing'
> gcc -DHAVE_CONFIG_H -I. -I..   -isystem /usr/src/linux-2.6.22/include/ -Wall
> -g -O2 -MT inet6_rth_space.o -MD -MP -MF .deps/inet6_rth_space.Tpo -c -o
> inet6_rth_space.o inet6_rth_space.c
> mv -f .deps/inet6_rth_space.Tpo .deps/inet6_rth_space.Po
> gcc -DHAVE_CONFIG_H -I. -I..   -isystem /usr/src/linux-2.6.22/include/ -Wall
> -g -O2 -MT inet6_rth_init.o -MD -MP -MF .deps/inet6_rth_init.Tpo -c -o
> inet6_rth_init.o inet6_rth_init.c
> mv -f .deps/inet6_rth_init.Tpo .deps/inet6_rth_init.Po
> gcc -DHAVE_CONFIG_H -I. -I..   -isystem /usr/src/linux-2.6.22/include/ -Wall
> -g -O2 -MT inet6_rth_add.o -MD -MP -MF .deps/inet6_rth_add.Tpo -c -o
> inet6_rth_add.o inet6_rth_add.c
> mv -f .deps/inet6_rth_add.Tpo .deps/inet6_rth_add.Po
> gcc -DHAVE_CONFIG_H -I. -I..   -isystem /usr/src/linux-2.6.22/include/ -Wall
> -g -O2 -MT inet6_rth_getaddr.o -MD -MP -MF .deps/inet6_rth_getaddr.Tpo -c -o
> inet6_rth_getaddr.o inet6_rth_getaddr.c
> mv -f .deps/inet6_rth_getaddr.Tpo .deps/inet6_rth_getaddr.Po
> gcc -DHAVE_CONFIG_H -I. -I..   -isystem /usr/src/linux-2.6.22/include/ -Wall
> -g -O2 -MT inet6_rth_gettype.o -MD -MP -MF .deps/inet6_rth_gettype.Tpo -c -o
> inet6_rth_gettype.o inet6_rth_gettype.c
> mv -f .deps/inet6_rth_gettype.Tpo .deps/inet6_rth_gettype.Po
> rm -f libmissing.a
> ar cru libmissing.a  inet6_rth_space.o inet6_rth_init.o inet6_rth_add.o
> inet6_rth_getaddr.o inet6_rth_gettype.o
> ranlib libmissing.a
> make[2]: Leaving directory `/usr/src/mipv6-daemon-umip-0.4/libmissing'
> Making all in libnetlink
> make[2]: Entering directory `/usr/src/mipv6-daemon-umip-0.4/libnetlink'
> gcc -DHAVE_CONFIG_H -I. -I..  -I../include -isystem
> /usr/src/linux-2.6.22/include/ -Wstrict-prototypes -Wall -g -O2 -MT
> libnetlink.o -MD -MP -MF .deps/libnetlink.Tpo -c -o libnetlink.o
> /libnetlink.c
> mv -f .deps/libnetlink.Tpo .deps/libnetlink.Po
> rm -f libnetlink.a
> ar cru libnetlink.a libnetlink.o 
> ranlib libnetlink.a
> make[2]: Leaving directory `/usr/src/mipv6-daemon-umip-0.4/libnetlink'
> Making all in src
> make[2]: Entering directory `/usr/src/mipv6-daemon-umip-0.4/src'
> make  all-am
> make[3]: Entering directory `/usr/src/mipv6-daemon-umip-0.4/src'
> gcc -DHAVE_CONFIG_H -I. -I..  -isystem ../include -isystem
> /usr/src/linux-2.6.22/include/ -Wall -Wpointer-arith -Wreturn-type -pedantic
> -std=gnu99 -g -O2 -MT pmgr.o -MD -MP -MF .deps/pmgr.Tpo -c -o pmgr.o pmgr.c
> mv -f .deps/pmgr.Tpo .deps/pmgr.Po
> gcc -DHAVE_CONFIG_H -I. -I..  -isystem ../include -isystem
> /usr/src/linux-2.6.22/include/ -Wall -Wpointer-arith -Wreturn-type -pedantic
> -std=gnu99 -g -O2 -MT main.o -MD -MP -MF .deps/main.Tpo -c -o main.o main.c
> mv -f .deps/main.Tpo .deps/main.Po
> gcc -DHAVE_CONFIG_H -I. -I..  -isystem ../include -isystem
> /usr/src/linux-2.6.22/include/ -Wall -Wpointer-arith -Wreturn-type -pedantic
> -std=gnu99 -g -O2 -MT vars.o -MD -MP -MF .deps/vars.Tpo -c -o vars.o vars.c
> mv -f .deps/vars.Tpo .deps/vars.Po
> gcc -DHAVE_CONFIG_H -I. -I..  -isystem ../include -isystem
> /usr/src/linux-2.6.22/include/ -Wall -Wpointer-arith -Wreturn-type -pedantic
> -std=gnu99 -g -O2 -MT conf.o -MD -MP -MF .deps/conf.Tpo -c -o conf.o conf.c
> mv -f .deps/conf.Tpo .deps/conf.Po
> gcc -DHAVE_CONFIG_H -I. -I..  -isystem ../include -isystem
> /usr/src/linux-2.6.22/include/ -Wall -Wpointer-arith -Wreturn-type -pedantic
> -std=gnu99 -g -O2 -MT gram.o -MD -MP -MF .deps/gram.Tpo -c -o gram.o gram.c
> mv -f .deps/gram.Tpo .deps/gram.Po
> /bin/sh ../ylwrap scan.l .c scan.c -- :  
> make[3]: *** [scan.c] Error 1
> make[3]: Leaving directory `/usr/src/mipv6-daemon-umip-0.4/src'
> make[2]: *** [all] Error 2
> make[2]: Leaving directory `/usr/src/mipv6-daemon-umip-0.4/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/src/mipv6-daemon-umip-0.4'
> make: *** [all] Error 2
> root@ha:/usr/src/mipv6-daemon-umip-0.4# 
> 
> 
-- 
Luis Campo Giralte     e-mail: lcg223@xxxxxx
TELEFÃNICA INVESTIGACIÃN Y DESARROLLO                                  
Protocolos y Nucleos de Red     
C/ Emilio Vargas 6 - 28043 Madrid - Spain